WordPress.org

Profiles

lukejanicke

Profile picture of lukejanicke
  • Member Since: February 9th, 2011
  • Guangzhou, China
  • www.lukejanicke.com
  • Find me on:

Bio/Description

Living, working, writing, programming in China

  • Posted a reply to "Multi-dimensional options array (for themes/plugins) with Settings API", on the site WordPress Support Forums:
    Great! Nice to know it helped someone.

    8 months ago

  • Created a topic, Gravatars @2x, on the site WordPress Support Forums

    8 months ago

  • Posted a reply to "Special characters in alt text break Picturefill method", on the site WordPress Support Forums:
    Nice one, mate! I can put those alt attributes back in my theme/plugin. Cheers!

    9 months ago

  • Posted a reply to "Bitly plugin doesn’t hook into wp_get_shortlink()?", on the site WordPress Support Forums:
    Should add… Bitly uses a lot of code and methods that I don’t understand. If…

    10 months ago

  • Created a topic, Bitly plugin doesn’t hook into wp_get_shortlink()?, on the site WordPress Support Forums

    10 months ago

  • Posted a reply to "WordPress default screen options", on the site WordPress Support Forums:
    Add one of the following hooks with the function (before or after, doesn’t matter). add_action(…

    10 months ago

  • Posted a reply to "“publish_post” action hook shouldn’t be depreciated! Why is it?", on the site WordPress Support Forums:
    I've updated the Codex in all the relevant places with current and correct information about…

    10 months ago

  • Created a topic, Post status transitions: updating the Codex, on the site WordPress Support Forums

    10 months ago

  • Posted a reply to "“publish_post” action hook shouldn’t be depreciated! Why is it?", on the site WordPress Support Forums:
    Resolved.

    11 months ago

  • Posted a reply to "Check my wp_mail() code? For a lite edit flow notifications plugin. (Github)", on the site WordPress Support Forums:
    I’ve figured it all out. More detail on how to make publish_post work is in…

    11 months ago

  • Posted a reply to "“publish_post” action hook shouldn’t be depreciated! Why is it?", on the site WordPress Support Forums:
    Yes. It works. The trick, apparently, seems to be putting '2' into the arguments of…

    11 months ago

  • Posted a reply to "“publish_post” action hook shouldn’t be depreciated! Why is it?", on the site WordPress Support Forums:
    I may have found answers but am yet to test them in my plugin. Firstly,…

    11 months ago

  • Posted a reply to "“publish_post” action hook shouldn’t be depreciated! Why is it?", on the site WordPress Support Forums:
    And perhaps the real crux of my question is what gets passed to these action…

    11 months ago

  • Created a topic, “publish_post” action hook shouldn’t be depreciated! Why is it?, on the site WordPress Support Forums

    11 months ago

  • Created a topic, Check my wp_mail() code? For a lite edit flow notifications plugin. (Github), on the site WordPress Support Forums

    11 months ago

  • Posted a reply to "How to customize "Insert Media" output?", on the site WordPress Support Forums:
    No worries, bcworkz. I'm also working on this on the side. I kinda get what…

    11 months ago

  • Created a topic, get_user_meta() vs. get_userdata() vs. get_the_author_meta(), on the site WordPress Support Forums

    11 months ago

  • Posted a reply to "How to customize "Insert Media" output?", on the site WordPress Support Forums:
    I’ve had a look at media-editor.js. I tried to strip down to the insert function…

    11 months ago

  • Created a topic, Special characters in alt text break Picturefill method, on the site WordPress Support Forums

    11 months ago

  • Posted a reply to "My plugin with 'the_content' filter breaks trying to add excerpt", on the site WordPress Support Forums:
    Solved. if ( has_excerpt() ) { $excerpt = get_the_excerpt(); $content = sprintf( '<p class="excerpt">%s</p>%s', $excerpt,…

    11 months ago

  • Posted a reply to "My plugin with 'the_content' filter breaks trying to add excerpt", on the site WordPress Support Forums:
    It works if there IS an excerpt. Perfectly. If there is no excerpt, the page…

    11 months ago

  • Created a topic, My plugin with 'the_content' filter breaks trying to add excerpt, on the site WordPress Support Forums

    11 months ago

  • Posted a reply to "Automatically rename files (on edit media)", on the site WordPress Support Forums:
    Not that you need to go look at it... but I’ve stripped down your plugin…

    11 months ago

  • Posted a reply to "How to customize "Insert Media" output?", on the site WordPress Support Forums:
    I’ll look into that. Not an insurmountable problem. Thanks for the clear explanation. I’ll post…

    11 months ago

  • Posted a reply to "Automatically rename files (on edit media)", on the site WordPress Support Forums:
    Yes yes :) I mean just the automatic renaming bit, thus with no Admin options…

    11 months ago

  • Posted a reply to "Automatically rename files (on edit media)", on the site WordPress Support Forums:
    I just noticed that happening. Very nice feature. So nice in fact that I want…

    11 months ago

  • Posted a reply to "It doesn't generate 2x for the original image.", on the site WordPress Support Forums:
    Alright guys, I don't get your use-case scenario so I’ll let Jordy figure what the…

    11 months ago

  • Created a topic, Automatically rename files (on edit media), on the site WordPress Support Forums

    11 months ago

  • Posted a reply to "Bulk edit media file Titles (not file names) or have them match their parent", on the site WordPress Support Forums:
    I too need a plugin that lets me select a bunch of images from the…

    11 months ago

  • Posted a reply to "How to customize "Insert Media" output?", on the site WordPress Support Forums:
    There must be a function that is called after images have been selected and options…

    11 months ago

  • Posted a reply to "It doesn't generate 2x for the original image.", on the site WordPress Support Forums:
    Kevin, what you’re saying (correct me if I’m wrong) is that your theme(s) is unable…

    11 months ago

  • Created a topic, How to customize "Insert Media" output?, on the site WordPress Support Forums

    11 months ago

  • Posted a reply to "Curious bug... @2x working for some, not for others", on the site WordPress Support Forums:
    Solved! Just had to strip_tags and esc_attr the alt text for the image. That was…

    11 months ago

  • Posted a reply to "Curious bug... @2x working for some, not for others", on the site WordPress Support Forums:
    I just noticed a correlation. The posts with working @2x thumbnails do not have any…

    11 months ago

  • Posted a reply to "Curious bug... @2x working for some, not for others", on the site WordPress Support Forums:
    I re-uploaded (even with a different name) one of the images (the Poker image). It’s…

    11 months ago

  • Posted a reply to "Curious bug... @2x working for some, not for others", on the site WordPress Support Forums:
    I’ll do that and post the results.

    12 months ago

  • Posted a reply to "'image' shortcode?", on the site WordPress Support Forums:
    I got it. The function for the shortcode needs to return the output, not echo/printf…

    12 months ago

  • Posted a reply to "'image' shortcode?", on the site WordPress Support Forums:
    Update: I changed the shortcode name to [newsimage] in functions.php and updated the shortcodes in…

    12 months ago

  • Created a topic, 'image' shortcode?, on the site WordPress Support Forums

    12 months ago

  • Posted a reply to "Advanced tab not working on iPad", on the site WordPress Support Forums:
    Resolved. When Safari is in private browsing mode, it doesn't work. I just had to…

    12 months ago

  • Created a topic, Curious bug... @2x working for some, not for others, on the site WordPress Support Forums

    12 months ago

  • Posted a reply to "It doesn't generate 2x for the original image.", on the site WordPress Support Forums:
    You would need to manually create and upload 'image@2x.jpg' because the plugin doesn't upsize an…

    12 months ago

  • Created a topic, Advanced tab not working on iPad, on the site WordPress Support Forums

    12 months ago

  • Posted a reply to "Category ID/slug from wp_get_nav_menu_items", on the site WordPress Support Forums:
    You are right. And I added a category type check. Thanks. function news_custom_menu( $location )…

    12 months ago

  • Created a topic, Category ID/slug from wp_get_nav_menu_items, on the site WordPress Support Forums

    12 months ago

  • Posted a reply to "A reset button for a theme’s settings page", on the site WordPress Support Forums:
    That was officially my first pull request and merge! I’m pretty new to Github and…

    1 year ago

  • Created a topic, A reset button for a theme’s settings page, on the site WordPress Support Forums

    1 year ago

  • Posted a reply to "[Plugin: Jetpack] Can't activate Markdown module", on the site WordPress Support Forums:
    Solution… (Note: Working on an iPad.) Tap and hold the 'Activate' button and copy the…

    1 year ago

  • Created a topic, [Plugin: Jetpack] Can't activate Markdown module, on the site WordPress Support Forums

    1 year ago

  • Created a topic, Multi-dimensional options array (for themes/plugins) with Settings API, on the site WordPress Support Forums

    1 year ago