WordPress.org

Profiles

jrcollins

Profile picture of jrcollins
  • Member Since: May 19th, 2012
  • @jrcollins on WordPress.org
  • Find me on:

  • Posted a reply to What to do when declaring a large number of variables in function?, on the site WordPress.org Forums:
    Ok, thanks for the advice @mariadanieldeepak.

    2 days ago

  • Posted a reply to What to do when declaring a large number of variables in function?, on the site WordPress.org Forums:
    Ok, thanks. The variables are only used in that function so I'll leave it the…

    2 days ago

  • Created a topic, What to do when declaring a large number of variables in function?, on the site WordPress.org Forums:
    I have a function in which I have declared a large num…

    2 days ago

  • Posted a reply to How to get widget settings?, on the site WordPress.org Forums:
    Hi @tsure, I got this to work by using the following code: $widget_instances = get_option('widget_category_grid');…

    4 days ago

  • Created a topic, How to get widget settings?, on the site WordPress.org Forums:
    I'm trying to access a widget's settings from outside …

    5 days ago

  • Posted a reply to How to add Ajax pagination to widget?, on the site WordPress.org Forums:
    By custom plugin I mean a plugin I created myself. The plugin adds a widget…

    1 week ago

  • Created a topic, How to add Ajax pagination to widget?, on the site WordPress.org Forums:
    I created a custom widget plugin which displays my sit…

    1 week ago

  • Posted a reply to include_once not working, on the site WordPress.org Forums:
    I got this to work by using include_once(dirname(__FILE__) . '/../tpls/frontend.php');

    2 weeks ago

  • Posted a reply to include_once not working, on the site WordPress.org Forums:
    I found this answer but if it's correct it should be possible to link to…

    2 weeks ago

  • Posted a reply to include_once not working, on the site WordPress.org Forums:
    Thanks, now I'm even more confused lol!

    2 weeks ago

  • Posted a reply to include_once not working, on the site WordPress.org Forums:
    There doesn't seem to be anything wrong with the file permissions. When I put the…

    2 weeks ago

  • Created a topic, include_once not working, on the site WordPress.org Forums:
    I've created a widget plugin and have placed the code …

    2 weeks ago

  • Created a topic, image size, on the site WordPress.org Forums:
    In the styling tab there is a field labeled "Height &a…

    2 weeks ago

  • Created a topic, How to hide widget if empty?, on the site WordPress.org Forums:
    Is there any way to hide the widget if it's empty?

    3 weeks ago

  • Posted a reply to PHP “do nothing”, on the site WordPress.org Forums:
    It's for a custom categories widget. There are 2 basic conditions I'm testing for: a…

    3 weeks ago

  • Created a topic, PHP “do nothing”, on the site WordPress.org Forums:
    What's the best way to handle the elseif statement in …

    3 weeks ago

  • Posted a reply to Call to undefined function error on category pages, on the site WordPress.org Forums:
    I tried copying the function to my child theme's functions.php file and I'm no longer…

    3 weeks ago

  • Created a topic, Call to undefined function error on category pages, on the site WordPress.org Forums:
    I'm getting this error on my site's category pages: Fa…

    3 weeks ago

  • Created a topic, check box custom field for custom category template, on the site WordPress.org Forums:
    I have a custom category template which displays the c…

    3 weeks ago

  • Posted a reply to Need help with Widget Logic code, on the site WordPress.org Forums:
    I managed to get this to work using the following code: $thiscat = get_category( get_query_var(…

    3 weeks ago

  • Posted a reply to Need help modifying code, on the site WordPress.org Forums:
    Ok, I think I've got it now: $thiscat = get_category( get_query_var( 'cat' ) ); $parent…

    3 weeks ago

  • Created a topic, Need help modifying code, on the site WordPress.org Forums:
    I'm using Widget Logic to stop a widget showing on par…

    3 weeks ago

  • Posted a reply to Need help with Widget Logic code, on the site WordPress.org Forums:
    Ok, thanks. I will.

    3 weeks ago

  • Created a topic, Need help with Widget Logic code, on the site WordPress.org Forums:
    I'm using the Widget Logic plugin to show a widget onl…

    3 weeks ago

  • Posted a reply to How to show widget only on child category pages?, on the site WordPress.org Forums:
    This works: $thiscat = get_category( get_query_var( 'cat' ) ); $parent = $thiscat->category_parent; return !(is_category( )…

    3 weeks ago

  • Created a topic, How to show widget only on child category pages?, on the site WordPress.org Forums:
    I'm trying to prevent a widget showing on parent categ…

    3 weeks ago

  • Posted a reply to How to get the parent category of the current category?, on the site WordPress.org Forums:
    Hey thanks! I was wondering what I was doing wrong.

    3 weeks ago

  • Created a topic, How to get the parent category of the current category?, on the site WordPress.org Forums:
    On child category pages I need to get the parent of th…

    3 weeks ago

  • Created a topic, How to customize HTML output for category list?, on the site WordPress.org Forums:
    I'm using wp_list_categories to display a list of cate…

    3 weeks ago

  • Created a topic, Display widget only on child category pages, on the site WordPress Support Forums

    4 weeks ago

  • Posted a reply to How to get child categories by id?, on the site WordPress Support Forums:
    Ok, that's easy. Thanks for your help.

    4 weeks ago

  • Created a topic, How to get child categories by id?, on the site WordPress Support Forums

    4 weeks ago

  • Posted a reply to Pagination for custom category template, on the site WordPress Support Forums:
    I finally managed to get this done. Here's the code: <?php /** * Category Template:…

    4 weeks ago

  • Posted a reply to Need help understanding pagination variables, on the site WordPress Support Forums:
    Ok, got it. Thanks for the explanation.

    1 month ago

  • Posted a reply to Unable to display pagination links, on the site WordPress Support Forums:
    Hi, thank you for the suggestions. I seem to have it working now. There was…

    1 month ago

  • Created a topic, Unable to display pagination links, on the site WordPress Support Forums

    1 month ago

  • Created a topic, Need help understanding pagination variables, on the site WordPress Support Forums

    1 month ago

  • Created a topic, 5 stars, on the site WordPress Support Forums

    1 month ago

  • Posted a reply to Pagination offset and paged variables, on the site WordPress Support Forums:
    Ok, after some more research I realize it's actually quite simple. The offset value tells…

    1 month ago

  • Created a topic, Pagination offset and paged variables, on the site WordPress Support Forums

    1 month ago

  • Created a topic, How to add pagination to custom category template?, on the site WordPress Support Forums

    1 month ago

  • Posted a reply to Pagination parameters, on the site WordPress Support Forums:
    Thanks, good explanation.

    1 month ago

  • Created a topic, Pagination for custom category template, on the site WordPress Support Forums

    1 month ago

  • Created a topic, Pagination parameters, on the site WordPress Support Forums

    1 month ago

  • Posted a reply to How to set up function?, on the site WordPress Support Forums:
    Just found out about the wp_trim_words() function which makes things a lot easier.

    1 month ago

  • Created a topic, How to set up function?, on the site WordPress Support Forums

    1 month ago

  • Posted a reply to Problem with foreach loop, on the site WordPress Support Forums:
    I solved this by replacing get_template_part( 'template-parts/content-grid' ); with include( locate_template( 'template-parts/content-grid.php' ) );

    1 month ago

  • Created a topic, Problem with foreach loop, on the site WordPress Support Forums

    1 month ago

  • Posted a reply to Hover effect issue, on the site WordPress Support Forums:
    Not sure what I did but it's actually working now. Thanks for the advice.

    1 month ago

  • Posted a reply to Hover effect issue, on the site WordPress Support Forums:
    Do you mean the SASS file is not being loaded? I'm using a child theme…

    1 month ago