WordPress.org

Ready to get started?Download WordPress

Profiles

James Huff

Profile picture of James Huff
  • Member Since: October 4th, 2004
  • macmanx.com
  • Happiness Engineer at Automattic
  • Find me on:

Bio/Description

I’m terrible at making these things short, so I’ll just say that I’m a Happiness Engineer at Automattic and a Support Forum volunteer. There’s more at http://macmanx.com/about/

WordPress Origin Story

I started using WordPress in 2004, ran into a problem right away, asked on the forums, and starting answering whatever threads I could. In 2010, I took a job as a Happiness Engineer at Automattic, providing support for bloggers at WordPress.com (a bit different from WordPress.org). After a few years away from the WordPress.org Support Forums, I’m trying to make a comeback. :)

  • Posted a reply to "WP One-click Update is not there", on the site WordPress Support Forums:
    Oh, that doesn't sound good at all. Maybe they wanted to lock you into their…

    31 mins ago

  • Posted a reply to "Cannot save widgets in WP 4.0", on the site WordPress Support Forums:
    Thanks for letting us know! Would you mind trying one more time with all of…

    32 mins ago

  • Posted a reply to "Thumbnail Does Not Load", on the site WordPress Support Forums:
    You're welcome!

    19 hours ago

  • Posted a reply to "Can't view dashboard", on the site WordPress Support Forums:
    Well, at least it works now! :)

    22 hours ago

  • Posted a reply to "Cannot save widgets in WP 4.0", on the site WordPress Support Forums:
    You're welcome! Which version of Firefox are you running?

    1 day ago

  • Posted a reply to "Get HTML5 audio player to play self-hosted files?", on the site WordPress Support Forums:
    You're welcome!

    1 day ago

  • Posted a reply to "WP One-click Update is not there", on the site WordPress Support Forums:
    Hm, possible. Are you logged in as the administrator on the blog? Can you see…

    1 day ago

  • Posted a reply to "Can't Login After Automatic 4.0 Upgrade", on the site WordPress Support Forums:
    You'll need to delete and replace all the files, except the wp-config.php file and the…

    1 day ago

  • Posted a reply to "images duplicating 1000 times with each image upload", on the site WordPress Support Forums:
    You need to get an updated WPML Media plugin from WPML.

    1 day ago

  • Posted a reply to "Can't Login After Automatic 4.0 Upgrade", on the site WordPress Support Forums:
    Right, but in your reply you said you only replaced two files. The solution posted…

    1 day ago

  • Posted a reply to "Html only on dashboard??", on the site WordPress Support Forums:
    I'm not seeing anything at http://www.leasepolice.co.uk/ now. It's reporting a DNS failure, which usually means…

    2 days ago

  • Posted a reply to "Can't Login After Automatic 4.0 Upgrade", on the site WordPress Support Forums:
    If the solution already posted above did not work for you, then you don't have…

    2 days ago

  • Posted a reply to "I can't switch back to text from the visual tab", on the site WordPress Support Forums:
    First, please take a look at the known issues and conflicts at https://wordpress.org/support/topic/wordpress-40-master-list If you…

    2 days ago

  • Posted a reply to "Updated to 4.0 and "The connection was reset" message", on the site WordPress Support Forums:
    Well, we can't really figure out what the problem is unless you're willing to troubleshoot…

    2 days ago

  • Posted a reply to "Hi, I seem to be having a database error problem", on the site WordPress Support Forums:
    You're welcome, please let us know how it goes!

    2 days ago

  • Posted a reply to "WP One-click Update is not there", on the site WordPress Support Forums:
    Oh, you're running WordPress Multisite? You should only be able to update from the Network…

    2 days ago

  • Posted a reply to "Admin panel hangs / blank screen", on the site WordPress Support Forums:
    You're welcome!

    2 days ago

  • Posted a reply to "Help creating a comment filtering script to stop spammers", on the site WordPress Support Forums:
    And thanks for the mention, James. My pleasure, and thank you for maintaining such an…

    2 days ago

  • Posted a reply to "Strange lines of code at top of dashboard", on the site WordPress Support Forums:
    You're welcome!

    2 days ago

  • Posted a reply to "WP 4.0 update made Media Library invisible", on the site WordPress Support Forums:
    It's probably not the same issue, perhaps the same symptoms, but not the same cause.…

    3 days ago

  • Posted a reply to "No Admin Panel", on the site WordPress Support Forums:
    You're welcome!

    3 days ago

  • Posted a reply to "4.0 full of bugs", on the site WordPress Support Forums:
    I've been in IT and web development for well over a decade, so I am…

    3 days ago

  • Posted a reply to "WordPress needs to inform us WHICH themes are supported or not", on the site WordPress Support Forums:
    If it is as you say, a community with many of the themes made by…

    3 days ago

  • Posted a reply to "Update to 4.0 error", on the site WordPress Support Forums:
    Who is your hosting provider? Also, are you using any sort of caching plugin, or…

    3 days ago

  • Posted a reply to "SPAM", on the site WordPress Support Forums:
    You're welcome!

    3 days ago

  • Posted a reply to "multiple 400 bad request errors", on the site WordPress Support Forums:
    Ok, so there was until 6 hours ago, no .htaccess file in your root directory,…

    3 days ago

  • Posted a reply to "I have WORDPRESS.ORG and I can't see store", on the site WordPress Support Forums:
    That is all handled through your hosting provider, you'll need to check their support documents…

    4 days ago

  • Posted a reply to "4.0 UPDATE NOT SHOWING IN WP DASHBOARD", on the site WordPress Support Forums:
    There were some issues with updating and GoDaddy's server configurations, some updated files may have…

    4 days ago

  • Posted a reply to "updating to wordpress 4.0", on the site WordPress Support Forums:
    Oh, and never rely on your host to do it for you. Unless they specifically…

    4 days ago

  • Posted a reply to "updating to wordpress 4.0", on the site WordPress Support Forums:
    If you go the plugin route, rather than the other routes on that guide, some…

    4 days ago

  • Posted a reply to "My Blog is not showing!", on the site WordPress Support Forums:
    You're welcome!

    4 days ago

  • Posted a reply to "I have WORDPRESS.ORG and I can't see store", on the site WordPress Support Forums:
    When you have a WordPress.org blog, you register domains via a domain registrar or your…

    4 days ago

  • Posted a reply to ""You do not have sufficient permissions to access this page"", on the site WordPress Support Forums:
    I recommend asking at http://wordpress.org/support/plugin/woocommerce so the plugin's developers and support community can help you…

    4 days ago

  • Posted a reply to "I have WORDPRESS.ORG and I can't see store", on the site WordPress Support Forums:
    The Store tab is only part of WordPress.com, which is an entirely separate entity by…

    4 days ago

  • Posted a reply to "Change name server - what happens next?", on the site WordPress Support Forums:
    Changing the name servers only directs the domain to the new hosting provider. You'll need…

    4 days ago

  • Posted a reply to "My Blog is not showing!", on the site WordPress Support Forums:
    Try manually resetting your plugins. If that resolves the issue, reactivate each one individually until…

    4 days ago

  • Posted a reply to "San Francisco Meetup", on the site WordPress Support Forums:
    Looks like a lot of people are interested: http://wordpress.meetup.com/cities/us/ca/san_francisco/ ;) Also, don't miss http://2014.sf.wordcamp.org/ More…

    4 days ago

  • Posted a reply to "Typing not showing up in New Post after upgrade to wp4", on the site WordPress Support Forums:
    First, check https://wordpress.org/support/topic/wordpress-40-master-list to see if you match any of the know issues or conflicts.…

    4 days ago

  • Posted a reply to "Edit page", on the site WordPress Support Forums:
    At Users -> Your Profile, make sure that "Disable the visual editor when writing" is…

    4 days ago

  • Posted a reply to "Images in RSS feed", on the site WordPress Support Forums:
    Read the reply above. If that doesn't work for you, please open your own thread:…

    4 days ago

  • Posted a reply to "Help creating a comment filtering script to stop spammers", on the site WordPress Support Forums:
    Yep, I linked to it in my first reply.

    4 days ago

  • Posted a reply to "Strange lines of code at top of dashboard", on the site WordPress Support Forums:
    As mentioned, "theme functions can interfere like plugins," especially since all of your errors note…

    4 days ago

  • Posted a reply to "Blogroll Plugins Need Updates", on the site WordPress Support Forums:
    Excellent, that works too if you know the HTML. :) I generally suggest Menus since…

    4 days ago

  • Posted a reply to "Yoast sitemap hick ups", on the site WordPress Support Forums:
    You're welcome! https://wordpress.org/support/topic/xml-hick-up-sometimes-alive-sometimes-disappeared

    4 days ago

  • Posted a reply to "Images not showing since 4.0 update", on the site WordPress Support Forums:
    What are you using to force HTTPS? Have you tried disabling that to see if…

    4 days ago

  • Posted a reply to "Fresh 4.0 multi-site installation, only default Permalinks work", on the site WordPress Support Forums:
    I did some searching, do either of these apply to you? http://guiem.info/permalinks-on-wordpress-amazon-ec2/ http://stackoverflow.com/questions/12292992/permalinks-on-wordpress-ec2

    4 days ago

  • Posted a reply to "Google does not show my blog", on the site WordPress Support Forums:
    Well, it hasn't been "a few weeks" yet either. ;) Your robots.txt file appears to…

    4 days ago

  • Posted a reply to "editing pencil still there", on the site WordPress Support Forums:
    You're welcome!

    4 days ago

  • Posted a reply to "Whitelisting the plugins AT wordpress.org email address", on the site WordPress Support Forums:
    You're welcome!

    4 days ago

  • Posted a reply to "Thumbnail Does Not Load", on the site WordPress Support Forums:
    Well, I'd consider it a must-have, but that's because I use many of it's modules.…

    4 days ago